======================================================= AIX: Mirroring rootvg ======================================================= :Title: AIX: Mirroring rootvg :Author: Douglas O'Leary :Description: How to mirror OS vg in AIX :Date created: 06/2000 :Date updated: 07/2001 :Disclaimer: Standard: Use the information that follows at your own risk. If you screw up a system, don't blame it on me... Although the steps to mirror volume groups between HP and AIX are incredibly similar, there are enough differences to send me through hoops if/when I ever have to do that. Therefore, the following checklist: #. Mirror the logical volumes: a. If you don't care what disks the lvs get mirrored to, execute:: mirrorvg rootvg b. Otherwise:: for lv in $(lsvg -l rootvg | grep -i open/syncd | \ grep -v dumplv | awk '{print $1}') do mklvcopy ${lv} 1 ${disk} done #. Change the quorum checking if you did not use mirrorvg:: chvg -Q n rootvg #. Run bosboot on the new drive to copy boot files to it:: bosboot ${disk} #. Update the bootlist with the new drive: bootlist -m normal hdisk0 hdisk1 #. Reboot the system to enable the new quorum checking parameter