AIX: Paging space information

Title:

AIX: Paging space information

Author:

Douglas O’Leary <dkoleary@olearycomputers.com>

Description:

How to get information on AIX paging space.

Date created:

Date updated:

Disclaimer:

Standard: Use the information that follows at your own risk. If you screw up a system, don’t blame it on me…

AIX paging space concepts are the same as other systems. How to access that subsystem, though, is naturally different. Here’s some information on the IBM/AIX paging subsystem.

Deactivating paging space:

Like most modern UNIXes, AIX systems must be rebooted in order to fully deactivate paging space. The full process is as follows:

  1. Unset the activation bit for the paging space in question:

    chps -a n ${lv}
    

#. Ensure the paging space that you are deactivating is not the default dump space. Update the default dump space to something else should that be the case:

# sysdumpdev -l
primary              /dev/dumplv
secondary            /dev/sysdumpnull
copy directory       /var/adm/ras
forced copy flag     TRUE
always allow dump    TRUE
dump compression     OFF

sysdumpdev -P -p ${new_dump_dev} # Sets the new dump device
  1. Reboot. shutdown -Fr now

  2. Confirm that the target paging space is no longer activated:

    # lsps -a
    Page Space  Physical Volume   Volume Group    Size   %Used  Active  Auto  Type
    paging00    hdisk3            rootvg        4096MB       1     yes   yes    lv
    hd6         hdisk2            rootvg        4096MB       1     yes   yes    lv
    
  3. Remove the paging space and logical volume:

    rmps ${lv}
    

Modifying default paging space:

Anytime you’re messing with the default paging space (other than increasing the size), you’re going to have to supply a temporary default paging space. The checklist that follows shows all the steps required to reduce the size of the default paging lv, hd6.

  1. Create a temporary paging space logical volume:

    mkps -a -n -s 30 rootvg ${disk}
    
  2. Deactivate hd6 paging space:

    chps -a n hd6

  3. Edit /sbin/rc.boot to update the swapon command from hd6 to the name output by the mkps command above (probably /dev/paging00).

  4. Update, if necessary, the system dump device.

    1. Identify existing dump device by executing sysdumpdev -l

    2. Update by executing sysdumpdev -P -p /dev/paging00

  5. Update the bootimage with the new paging/dump information by executing bosboot -d /dev/hdisk0 -a

  6. Ensure the system key, if present, is in the normal position and reboot the system.

  7. After the sytem is up, ensure hd6 isn’t being used by executing lsps -a

  8. Remove hd6 by executing rmps hd6

  9. Create a new hd by executing mklv -t paging -y hd6 rootvg 30

  10. Change the dump device back to hd6 by executing sysdumpdev -P -p /dev/hd6

  11. Edit /sbin/rc.boot to update the swapon command from the temporary to hd6.

  12. Update the bootimage with the new paging/dump information by executing bosboot -d /dev/hdisk0 -a

  13. Activate hd6 by executing chps -a y hd6

  14. Deactivate the temporary paging space by executing chps -a n paginng00

  15. Ensure the system key, if present, is in the normal position and reboot the system.

  16. When the system is back up, remove the temporary paging space by executing rmps paging00