AIX: Mirroring rootvg

Title:

AIX: Mirroring rootvg

Author:

Douglas O’Leary <dkoleary@olearycomputers.com>

Description:

How to mirror OS vg in AIX

Date created:

06/2000

Date updated:

07/2001

Disclaimer:

Standard: Use the information that follows at your own risk. If you screw up a system, don’t blame it on me…

Although the steps to mirror volume groups between HP and AIX are incredibly similar, there are enough differences to send me through hoops if/when I ever have to do that. Therefore, the following checklist:

  1. Mirror the logical volumes:

    1. If you don’t care what disks the lvs get mirrored to, execute:

      mirrorvg rootvg
      
    2. Otherwise:

      for lv in $(lsvg -l rootvg | grep -i open/syncd | \
         grep -v dumplv | awk '{print $1}')
      do
         mklvcopy ${lv} 1 ${disk}
      done
      
  2. Change the quorum checking if you did not use mirrorvg:

    chvg -Q n rootvg
    
  3. Run bosboot on the new drive to copy boot files to it:

    bosboot ${disk}
    
  4. Update the bootlist with the new drive:

    bootlist -m normal hdisk0 hdisk1

  5. Reboot the system to enable the new quorum checking parameter